Synth Arpeggiator & Drum Pad

Synth Arpeggiator & Drum Pad
Compatible Devices iPad (3rd/1st generation), iPad2 (2nd generation) * For best performance, we recommend that you use iPad2 or later.
Compatible OS Requires iOS 5.0 or later
Language English, Japanese